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Getting Started with ODTK 

This exercise will give you hands-on experience with the ODTK user interface.  

TIP: AGI recommends that you print out this document instead of attempting to use it on screen, 

since the PDF is optimized for printing rather than computer display. Also, if you display this doc-

ument in an integrated HTML window, it will be displaced by some of the windows that you 

launch in the course of doing the exercise. 

In the following pages, you will proceed step by step to set up and run a sequence of OD tasks:  

• Initial Orbit Determination (IOD) 

• Least Squares (LS) 

• Optimal Orbit Determination (OOD) using a filter and each of two smoother algorithms 

(a VLS smoother and an RTS  smoother) 

In addition, you will become familiar with ODTK’s reporting and graphing capabilities. 

1 Access ODTK Help 

Before starting this exercise, AGI recommends that you become familiar with the online ODTK 

Help system and briefly review the introductory chapters. Select ODTK Help from the Help 

menu: 

 

AGI recommends that you review the “Using ODTK” section before starting the following tasks.  

In addition, you may want to reference the “OD Objects & Attributes” and “Reports & Graphs” 

sections as you run through the following tasks. 

Before continuing, either minimize or close ODTK Help using the appropriate button on the ODTK 

Help Title Bar. 

2 Set up some OD assets 

To define the context for the OD tasks to follow, you will create an OD scenario and populate it 

with objects representing a tracking system, a satellite and a transponder. You will then practice 

using the OD user interface — in particular the Object Browser and the Object Properties win-

dow — to set properties for those objects. 



 

 

Getting Started With ODTK (Version 7) 2 

1. Create a scenario by clicking the scenario button  on the ODTK toolbar. Then add a 

satellite to the scenario by clicking the satellite object button . 

NOTE: To access object buttons, click the downward pointing   button on the De-

fault toolbar, which displays other objects that you can attach to a selected object. 

You will use this same procedure to switch back and forth between the IOD and LS 

buttons when a satellite is highlighted (see below). 

2. With the scenario highlighted in the browser, select Import → Import Object from the 

File menu.  

3. In the lower-right corner of the file selection dialog box, use the drop-down menu to set 

the file search type to TrackingSystem Files (*.tso). Open the file Baseline.tso, which is 

located at <ODTK Install>\ODTK\AppData\Databases\TrackingSystems\Baseline.tso; this 

loads a tracking system. 

4. Highlight the satellite and click  on the Default toolbar, and select Transponder (  ). 

The Browser should appear as follows at this stage: 

 

5. Double-click the scenario in the Browser to expose its properties. Select the Measure-

ments → Files property: 

 

6. Click where it says “click to edit.” In the Scenarios.Measurements.Files dialog box that 

appears, click the Add button. 
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7. Double-click the Filename field and load the file V1001.geosc, which is located at <ODTK 

install>\ODTK\UserData\TrackingData\. Click OK to save this and close the dialog box; 

the Object Properties window will be marked to indicate that you changed a property: 

 

8. Apply the property change by clicking Apply in the upper-left corner of the Object Prop-

erties window. 

NOTE: From this point forward in this exercise, when you are instructed to "Apply the 

property change(s)," it means to follow the above procedure. 

TIP: If you change your mind about changes you made in the Object Properties window 

before clicking Apply, click Reset to restore the values of the affected properties to their 

values prior to the changes.  

9. Open the Object Properties window for the satellite and, under Orbit State, change its 

Epoch to 1 Jun 2015 12:00:00.000 UTCG. 

10. Then scroll down to the OrbitUncertainty attributes and make the following changes: 

• R_sigma: 500 m 

• I_sigma: 10000 m 

• C_sigma: 100 m 

• Rdot_sigma: 0.6 m/s 

• Idot_sigma: 0.4 m/s 

• Cdot_sigma: 0.2 m/s 
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11. Click Apply. Click the  (Preview Measurements) icon and observe that the results of 

the loading operation are displayed in the Message Viewer window: 

 

 

NOTE: It sometimes takes several seconds for ODTK to carry out an action and display 

the results in the Message Viewer window.  

3 Perform Some OD tasks 

3.1 Initial Orbit Determination (IOD) 

1. With the satellite highlighted, click the downward pointing  button on the Default 

toolbar and select the  button to add an Initial Orbit Determination object.  

2. Open the IOD object's properties, and make certain that Method is set to HerrickGibbs, 

and that the SelectedFacility is REEF-A. Confirm any changes that you had to make. 
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3. Click the SelectedMeasurements field, and, in the List window that appears, click the 

Add button to display the Add Item(s) window.  

4. Select data points 0000, 0020, and 0040. 

TIP: To multi-select items, hold down the CTRL button and click the left mouse button on 

each desired item. 

 

5. Close the Add Item(s) and List windows by clicking OK and apply the property changes. 

6. Highlight the IOD in the Object Browser and click the  (Run) button on the toolbar to 

run it. Note the changes in the Object Properties window. The Message Viewer window 

will indicate when IOD is finished. 

7. Now transfer the results of the IOD to the initial state of the satellite. With the IOD still 

highlighted, click the  (Transfer to Satellite) icon and note the confirmation in the 

Message Viewer window. 

3.2 Least Squares (LS) 

1. Highlight the satellite again and attach a Least Squares object using the  icon. Dou-

ble-click the LS object to expose its properties, and click the Run button  to run Least 
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Squares. Observe the changes in the Object Properties window and in the Message 

Viewer window. 

2. Again, click the  (Transfer to Satellite) button to transfer the LS results to the satel-

lite's initial state, again noting the confirmation in the Message Viewer window. 

3.3 Optimal Orbit Determination (OOD) with the Filter 

1. Highlight the scenario in the Browser and click the  icon to insert a filter.  

2. Double-click the filter object to expose its properties.  

3. Find MeasTypes and click the “click-to-edit” area; the Filter.MeasTypes dialog box ap-

pears.  

4. Click the Add button, select Range and Doppler from the Add Item(s) list, and click OK 

twice. Apply the property changes. 

 

 

5. From the View menu, select Dynamic Product Selector.  

6. In the Dynamic Reports dialog box, make certain that Report is selected as the Dynamic 

Display format, that Satellite is selected as the Object Type, that all Styles except “In-

stant Maneuver Estimate Update” are selected, and that the satellite is highlighted in 

the Satellites column.  

7. Click the Create button. 
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8. Click the lower Dynamic Reports tab to return to the Dynamic Product Selector.  

9. Select Graph as the Dynamic Display format and Satellite as the ObjectType. Select 

Dyn_Range_Residual in the Styles column, and make certain that the satellite is high-

lighted in the Satellites column.  

10. Click the Create button to display the following window: 

 

11. Now, with the filter highlighted in the Browser, run it. Monitor the OOD process via the 

T (Filter Time Update), M (Filter Measurement Update), and Trackers windows. Selected 

data will appear dynamically in the graph window: 
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The Message Viewer window will indicate when filtering is done. 

NOTE: Depending on the number of measurements involved, the filtering process can 

take a while. 

3.4 OOD with the Variable Lag Smoother (VLS) 

ODTK has two smoothing algorithms. One is a forward-running variable time lag sequential 

smoother that runs with the filter and is a child of the filter object. This algorithm is called the 

Variable Lag Smoother (VLS). You enable it by setting the Filter → ProcessControl → EnableVLS 

property to true and then inserting a VLS object under the Filter. The second is a backward-run-

ning Rauch-Tung-Striebel (RTS) sequential smoother, which runs after the filter is completed. It 

requires the filter to provide data to the smoother via a set of “*.rough” file(s). You enable this 

smoother by inserting a Smoother object to the Scenario. 

1. To employ the VLS, first double-click the filter in the Object Browser to expose its prop-

erties.  

2. Verify that the Filter → ProcessControl → EnableVLS property is set to true.  

3. With the filter still highlighted, click the downward pointing  button on the Default 

toolbar and select the  button to insert a VLS.  

4. Double-click the VLS object to expose its properties. Set the VLS → Output → FilterDif-

ferencing → Generate property to true.  

5. Highlight the filter in the Object Browser and run it by clicking the  (Run) button in the 

ODTK toolbar. ODTK generates a *.filrun file, a *.smtrun file, and a *.difrun file for use 

by the Static Product Builder Reporting and Graphing interface. 
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3.5 OOD with the Rauch-Tung-Striebel (RTS) Smoother 

1. To employ the RTS, first highlight the filter in the Browser and double-click to expose its 

properties. Set the Filter → ProcessControl → EnableVLS property to false.   

2. Set the Filter → Output → SmootherData → Generate property to true. This exposes 

the Filter → Output → SmootherData → Filename property. This property is the name 

of the *.rough file that ODTK uses to pass data from the filter to the RTS smoother.  

3. Highlight the filter in the Browser and run it by clicking the  (Run) button in the ODTK 

toolbar. This will create a *.filrun file and a *.rough file. 

4. Highlight the scenario in the Object Browser, click the downward pointing  button on 

the Default toolbar, and select the  button to insert a smoother object.  

5. Double-click the smoother object to expose its properties.  

6. Go to Smoother → Input → Files and click the “click to edit” area; the Smoother.In-

put.Files dialog box appears.  

7. Click the Add button and click under Filename. Load the *.rough file that was generated 

by the filter (given by the Filter → Output → SmootherData → Filename property) and 

click OK to close the dialog box.   

8. Set the Smoother → Output → FilterDifferencingControls → Generate property to true.  

9. Highlight the smoother in the Browser and run it by clicking the  (Run) button in the 

ODTK toolbar. ODTK will generate a *.smtrun file and a *.difrun file for use by the Static 

Product Builder Reporting and Graphing interface. 

4 Reporting and graphing features 

You gained some experience above with dynamic reports and graphs that continuously update 

during a filter run. Here you will create a static report and graph on the basis of the output of a 

completed filter run. 

NOTE1: The activities in this section require the filter output that is generated by the ac-

tivities in the preceding sections. If you have not yet completed those activities, you 

must do so before proceeding. 

NOTE2: The technique to generate static report and graphs for a completed smoother 

run is similar. The smoother run file will have the extension “.smtrun”. However, some 

reports and graphs (like residuals and histograms) that apply to the filter do not apply to 

the smoother since neither smoother type does measurement modeling.  Also, there 

are no dynamic graphs associated with the smoother. 

4.1 Static reports 

The following activity will give you a sample of ODTK’s powerful reporting capabilities. 

1. From the View menu, select the Static Product Builder.  
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2. Click the Inputs tab.  

3. In the Data Source area, click the Add button 

4. Click where indicated in the Filename field and load the filter run (*.filrun) file that you 

created above. 

 

5. Click the Outputs tab and select the Residuals with Bias by Tracker report style from the 

Products Styles list.  

6. Click on the default name for the report (on the left side of the window) and rename it: 
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7. Now click the  (Run Selected) icon to launch the Report Viewer window. As you can 

see, the report lists measurements by facility and, per your specifications, is limited to 

range and Doppler measurements: 

 

8. Right-click the Report and select Export to Microsoft Excel. This exports the report data 

to an Excel spreadsheet. 

9. Close the report, but leave the scenario open to continue with this exercise. 

4.2 Static graphs 

NOTE: The activities in this section require the filter output that was generated in the 

preceding sections. If you have not yet completed those activities, you must do so be-

fore proceeding. 

Now you will create a static graph on the basis of the output of a completed filter run.  

1. From the View menu, select the Static Product Builder unless it is already open. If the 

Static Product Builder is already open, click the  icon to add a new data product to 

the list on the left side of the window and rename it. 

2. Click the Inputs tab.  
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3. In the Data Source area, if the *.filrun file that you created earlier is not already loaded, 

click the Add button, double-click where indicated in the Filename field, and load the 

file.  

4. In the Data Limiting area, limit Measurement Type to Range and Tracker Name to REEF-

A.  

5. Select each one and use the right arrow button to move it from the Available list to the 

Selected list. 

 

In this exercise, you will create a histogram.  

6. Click the Outputs tab and select the Histogram graph style (preceded by the icon ): 
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7. Now click the  (Run Selected) icon: 

 

The graph shows the percentage of range residuals in various sigma intervals compared to a 

Gaussian (normal) distribution. 

8. Right-click the mouse over one of the vertical bars to display a local shortcut menu for 

that area of the graph: 
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Experiment with some of the various options available; not all options necessarily have an effect. 

4.3 Graphical residual editing 

In this exercise, you will use ODTK’s graphical residual editor.  

1. Return to the Static Product Builder page by clicking the lower tab; click the Outputs tab 

if necessary.  

2. Copy the Histogram graph in the Products area and rename it.  

3. Select the Residual Ratios graph style (preceded by the icon ).  

4. Next, click the Inputs tab, and clear the Data Limiting selections by clicking  if neces-

sary.  

5. Now click the  (Run Selected) icon to generate a graph of residual ratios, which are 

measurement residuals divided by their standard deviations.  

6. After the graph appears, click the  icon in the upper left of the graph to display the 

Selected Points pane. 

7. Place the cursor on graph. Drag the cursor while holding down the left mouse button to 

expose the selection cursor  in order to “lasso” a square region, like this: 
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8. When you release the left mouse button, the edited points become marked and the se-

lected list fills on the right-hand side, like this: 

 

All measurements associated with the points in this region have now been marked for editing.  

9. To clear all points, lasso them again. Using the graphical zoom feature can help isolate 

individual measurements. 

10. When you are done selecting points, click the Reject button. When you apply your selec-

tion, the points will disappear from the Selected Points pane and the markers will disap-

pear from the graph, although the graphed points themselves will not disappear. 
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11. To verify that the points have been applied, double-click the filter object to expose its 

properties. In the filter’s property hierarchy, find Filter → Residual Editing → Schedule, 

and double-click it. Here you should see additions to the editing schedule created by the 

graphical editor. The next time you run the filter, ODTK will ignore the measurements 

identified within the schedule. It is also possible to edit this schedule manually. 

12. Rerun the filter and generate a new residual-ratios graph. Notice that the result is 

slightly different than before; this is because different data were used. 

This exercise has touched on just a few of many display and formatting options — and on only 

two of many graph styles — that are available for analysis using ODTK. You can also customize 

report and graph styles. To do this, click  on the Outputs pane to make a new report or 

graph style from an existing one. You can also click  to start a new graph. 


