Measurements

To select a tracking data file, click the Value field. In the List window that displays, click the Add button and click the FileName field. Select the desired tracking data file in the selection window that appears. If AliasMapping strings were set in the Tracking ID Aliases lists for any applicable objects, then select the associated AliasMapping string from the drop-down list of choices. These choices are assembled from those entered at the object level.

The AliasMapping value defaults to the last selected value. If you are going to select multiple files and want them to all use the same AliasMapping setting, set the AliasMapping prior to selecting the tracking files.

Default tracking data file extensions can be set in the Plugins tab of the Options window (accessible from the Tools menu). You can also add your own custom scripts for loading tracking data in the Plugins tab. Set the Enabled field for each file to true or false, depending on whether you want to use it.

Round Trip Representation

The RoundTripRepresentation attribute refers to ground-based range and Doppler measurements and space based range measurements, where there is a leg from the tracker to the satellite and then another leg from the satellite to the tracker. The following options are available:

RoundTripRepresentation Attribute Settings
Option Description
OneWay The default option. One-half of the round-trip range, or roughly the distance between the tracker and the satellite.
TwoWay The entire distance traveled from the tracker to the satellite and back.

The setting for RoundTripRepresentation at the scenario level is reflected in a read-only field for range and Doppler measurement statistics and affects the numerical values displayed for the constant bias, the Gauss-Markov bias sigma and the white noise sigma.

LookAheadBufferSize

The LookAheadBufferSize is an integer with valid values from one (1) to 100000 (default value is 100). It controls the size of the internal LookAheadBuffer for each input file used for sorting observation in the time order and applying measurement models that require multiple observations. If you set LookAheadBufferSize = 1, you will effectively disable time order sorting of the orbs from each file. If you set this value too large, you will increase memory use and decrease application responsiveness when it loads large batches of obs.

Embedded White Noise Sigmas

The EmbeddedWNSigmas attribute enables you to import an observation white noise sigma error statistic with each measurement from the *.GEOSC or *.navsol file types.

EmbeddedWNSigmas Settings
Option Description
Use Set to true if the estimation process (Filter or Least Squares) is to use the measurement white noise statistic embedded in the measurement file rather than the white noise value from the MeasurementStatistics table on the tracking object (Facility, Satellite, GPS Receiver). Otherwise set to false.

NOTE: If the input measurement file type does not include embedded white noise sigmas, then this attribute is ignored. Currently only the *.GEOSC and .navsol file types support embedded white noise sigmas.

OnInputError Applies only when EmbeddedWNSigmas.Use = true. This sub-attribute identifies how the estimation process should handle an invalid white noise sigma value input (e.g. blank, <=0, not a number).
  • RejectMeas - the measurement is ignored (not processed).
  • UseDefaultWNSigma - the white noise value from MeasurementStatistics table associated with the tracking object is used.

View and Save

The Custom Data Editing attributes provided at the Scenario level allow you to tailor the reporting of measurements or the saving of measurements. When applied to the saving of measurements, these attributes allow you to define specific criteria for reducing a large tracking data file to a smaller file that contains only the data you want to process, allowing for faster processing times.

The schedule attributes are identical to those for the Filter and Least Squares objects, however, the schedule here is only applied when either viewing measurements using the View Measurements tool or saving measurements to a file using the Save Measurements tool; it does not affect what measurements would be processed in a filter or least squares run.

Additionally, one of the choices for the Action attribute is ForceReject; however, this has no effect when viewing or saving measurements, as there are no residuals to be rejected. Use the Ignore option instead.

ODTK 6.5