Edit Menu

The ODTK Edit menu includes the following items, among others, for creating and rearranging objects in the Browser:

Edit Menu
Item Description
Cut Copy the currently selected object (and its subobjects, if any) to the clipboard and delete it from its present location. This is used when you want to move the object from one location to another, for example: to move an IOD object from one satellite to another.
Copy Copy the currently selected object (and its subobjects, if any) to the clipboard without deleting it from its present location. This is used when you want a copy of the selected object to be used as a basis for creating another object of the same type, for example: to create a new satellite with attached LS and IOD objects on the basis of one you have already defined.
Paste Attach the cut or copied object to the object selected in the Browser. This option is disabled if the selected object is not eligible to receive as a subobject the type of object that has been cut or copied.
Delete Delete the object selected in the Browser.
Find Displays a window that enables you to search for objects in the Browser with specified names or containing specified characters or alphanumeric sequences.
Preferences Displays the Preferences window that allows you to set application preferences (see below).

NOTE: Edit menu items not included in the above table, to the extent they are implemented in the current version of ODTK, operate as in other Windows applications.

TIP: You can access edit options by selecting an object in the Browser and right-clicking the mouse. The right-click popup menu also includes an option that lets you rename the object.

Preferences Window

Select Edit -> Preferences... to display the Preferences window, which contains the following tabs:

Preferences Window
Tab Description
File Find Specifies the paths to be searched for specified types of files, such as help files. To view path information, select the file type of interest from the dropdown list, then examine the list in the Directories area. Where more than one path is given, ODTK searches them in the order listed.

To edit a given path, double-click it. To add a path, click the (New/Insert) button and enter or browse for the desired path. To remove a path, select it in the Directories area and click the (Delete) button. The (Move Up) and (Move Down) buttons let you reorder the priority of multiple paths.
HTML Viewer
Displays the URL for the home page for the HTML Viewer.

Message Viewer Lets you determine which columns to display in the Message Viewer. Use the Add and Remove buttons to move headings back and forth between the Columns not shown and Columns shown areas, or simply double-click an item to move it from one area to the other.
Plugins

This tab lets you manage the types of tracking data files to be used in your OD tasks. Listed here are the file extensions, a brief description, and the PluginID (tracking data file loader, implemented in a programming language compatible with a COM interface) for each type. Buttons are provided for adding and removing file types. If you use only one or two of the types that are shipped with ODTK, you may find it convenient to remove the others, since it will simplify the process of selecting tracking files.

You can also create and add your own plugin scripts for the loading of tracking data files.

Tip: See below for a suggested procedure for editing a tracking data plugin entry (which you may have unintentionally removed or invalidated) without losing changes that you have made in other entries.

Runtime Settings

Lets you set the following runtime options.

  • Do Not Persist - Do not persist Runtime Settings to the config file - use them for current session only.
  • Use Optimized Math Library - Enable or disable use of Intel MKL.
  • Number Of Threads - How many threads MKL should use (0 - let MKL do dynamic control).
These preferences are also controllable via scripting interface as ODTK.Application.RuntimeSettings.
Simulator The Default File Extension option is used to specify the tracking data file format that the simulator will default to when simulating measurements.
UI Plugins

UI Plugin preference options allow you to manage all registered plugins.

Plugin Settings

The Plugins table displays the following information for all registered plugins. For more information on how plugins are registered, see Plugin Registration.

Name. Read-only field that displays the name of the plugin.

UiPlugin. Click the button in the UiPlugin field to view or modify the settings for the selected UI plugin. To modify a property, double-click its value.

Active. A check indicates that a valid UI plugin is running. In order for the plugin to be running, the following must be true:

  • The assembly must be registered for COM Interop.
  • The XML manifest must be properly formatted, named properly, and stored in the proper location. For more information, see Manifest Location.
  • The ProgID and DLL in the XML manifest must match that of your UI plugin.

If Active is not checked and all the above statements are true, open the Message Viewer and look for any related error messages.

Advanced Options

To display user-specified version information from the xml plugin registration file for the selected UI plugin, click Details.... For more information on the location of the xml plugin registration file, see Manifest Location. For information on adding version information to the registration file, see "Engine Plugin Registration" in the Programming Interface help system, which is accessible from the Help menu.

UI Integration & Recovery

To reset any toolbar currently edited using the selected UI plugin, click Reset Toolbars.

Manifest Location

When ODTK starts, it searches for xml files contained in identified folders and registers all plugins declared in each xml file found. Any changes made to these files after start-up will not take effect until the next time the application starts. ODTK looks at the following folders for xml plugin registration files:

  • <ODTK installation folder>\ODTK 6\Plugins.
  • Windows All Users Application area:
    • Windows XP: C:\Documents and Settings\All Users\Application Data\AGI\ODTK 6\Plugins
    • Windows Vista and 7: C:\ProgramData\AGI\ODTK 6\Plugins
  • Windows Configuration area:
    • Windows XP: C:\Documents and Settings\<user name >\My Documents\ODTK 6\Config\Plugins
    • Windows Vista and 7: C:\Users\<user name>\My Documents\ODTK 6\Config\Plugins

XML registration files located in the following folders are available for every user:

  • <ODTK installation folder>\ODTK 6\Plugins
  • <Windows All Users Application area>\AGI\ODTK 6\Plugins

XML registration files located in <Windows Configuration area>\Plugins will be available only for that user.

Note: If you want your settings on this page to remain in effect during subsequent ODTK sessions, select the Set as Default checkbox at the bottom of the Options dialog box.

Units

This tab lets you specify the default units for date and time to be used in any new scenario created in ODTK. The options are GPSG and UTCG. This setting does not change the units in an existing scenario. To change the default units in an existing scenario Scenario.Units.DateFormat attribute should be changed.

Note: The DateTime unit is the only unit presently available to be set in this tab.

Workbooks

Use this tab to define the behavior of your ODTK workbooks. Workbooks are used to save your specific workspace settings (custom toolbars, etc.). There are two types of workbooks used by ODTK.

  • Application workbooks define the default workspace to be used when a new scenario is created. Settings for application workbooks are saved in your user configuration area.
  • Scenario workbooks are tied to a scenario and save your specific workspace settings with the scenario so that the next time you open the scenario, your workspace configuration is restored. Scenario workbook settings are saved in a separate file but in the same directory as the scenario.

See below for step-by-step instructions for configuring workbooks.

Workbooks Settings

Follow these steps:

  1. Toggle the Show Transition Graphic option to show or hide the transition screen that is displayed when you open or close a workbook.
  2. Toggle the Show Startup Splash Screen option to show or hide the splash screen that is displayed when you start the application.
  3. Select Logging to log each time a specific workbook is used.
  4. Select Turn Off All Workbooks if you do not want to work with workbook files. With workbooks disabled, you cannot save workspace configurations to be used on loading of specific scenarios or creation of new scenarios.
  5. De-select Show LaunchPad on Startup (enabled by default) if you do not want LaunchPad to display upon startup of ODTK.
  6. Select the Scenario Auto Load and Auto Save options to automatically save and load scenario workbooks.
  7. Click Apply to save your changes, or OK to save and close the Options dialog box.

In the Application area of the Workbooks tab, the two buttons are disabled (grayed) when a scenario is loaded. The application workbook is loaded when the application is first loaded or after a scenario is closed. The application workbook is saved before a scenario is loaded or when the application is closed, if a scenario is not currently loaded.

Editing a Removed or Invalidated Tracking Data Plugin Entry

Normally, if you make a change to the Tracking Data File Providers list, other entries in the list are restored to default values when you exit the application. To prevent the loss of any settings you made to those other entries, follow this procedure:

  1. Before exiting the application, go to your OD Took Kit 6 home directory (usually ..\My Documents\ODTK 6\Config\) and save the preferences file (ODTK Prefs.xml) under another name, such as ODTK Prefs.bak .
  2. Save your changes to the Plugins tab and exit the application.
  3. Use a merge tool to compare the backup file to the newly created preferences file, so that you can identify any settings that were restored to default values. Copy those settings from the backup file into the appropriate location in the preferences file.

If you do not have a merge tool, you can display the two XML files side by side with a text editor and compare them visually.

ODTK 6.5