The following topic describes the system requirements needed by the API for Java.

The STK Scalability API for Java requires Java version 5 or greater.

Applications can be developed using any Java IDE. The provided sample applications include project files for Eclipse 3.5.

Supported Operating Systems

  • Windows 7
  • Windows 8
  • Windows 8.1
  • Windows Server 2008
  • Windows Server 2012

Development Environment

In order to develop applications using the API for Java, the following development tools need to be installed.

  • Java SE Development Kit (JDK) - download from here